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Introduction 
PedCath is a congenital cath reporting tool and database. It allows clinical staff to create a cath 
procedure report for patients with congenital heart defects. The report contains hemodynamic 
measurements (full and summary), calculations, diagnoses/procedure codes, physician notes, and a line-
drawn heart diagram specific to the patient (over 1500 Mullins starter diagrams are available which can 
be modified with drawing tools).  

PedCath is a "networkable" desktop application. You must install PedCath on each computer on 
which you want to use it, and each running instance of PedCath must have read/write access to the 
Data Folder. The Data Folder contains the PedCath database files and other files (such as diagrams, 
images, and documents) that are linked to cath records. The Data Folder may also contain export 
and import files, PedCath update files, patient and stock diagram templates, document templates and 
various configuration files. 

 

Responsibilities of the PedCath Administrator 
Using PedCath requires that at least one staff member of your institution be assigned as a PedCath 
administrator. The following are the responsibilities of the PedCath administrator and internal support 
staff. If you have questions or issues with any of the support tasks, please contact Scientific Software for 
assistance. Details of these tasks are given in the following sections. Once the initial setup is complete 
the workload for the administrator is expected to be a few hours a month or less. 

The responsibilities of the PedCath administrator are as follows: 

 Initial setup 

 Managing user accounts 

 Configuration changes 

 Setting up Backups (and handling restorations if necessary) 

 Running database maintenance 

 Updating annual license file / Adding licensed features 

 Troubleshooting PedCath issues 

 Upgrades 

 

Initial setup  
Scientific Software will send you download links to the PedCath installer as well as customized self-
extracting zip packages for blank and sample databases.  To set up PedCath you’d just need to create a 
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share folder that’s accessible to users (and grant those users read/write access to it) and unzip the blank 
database there. The PedCath installer would need to be run on each workstation (or using virtualization 
software such as Citrix), and you would point to the database location on the first startup. 

Please refer to the Installation guide of the manual for more information on the basic setup. 

https://www.pedcath.com/pdfs/Install8.pdf 

Interfacing with your hemodynamics system will require working with your hemodynamics vendor to 
send the interface files to the PedCath import folder. Sending the reports to the EMR would require 
working with your EMR interface team to pick up the PedCath exports and map them into the EMR. 

White papers and samples are available for interfacing.  

A sample implementation plan can be found here: 

https://www.pedcath.com/pdfs/PedCath_Implementation_Guide.pdf 

System Requirements 
Local Computer 

Minimum Specifications 

Pentium III 500 MHz or equivalent processor 

128 MB RAM (or minimum required by operating system). 

Windows 98, NT 4.0, 2000, XP or Windows 7/8/10/11 operating system 

64 MB video adapter memory, 1024 x 768 resolution 

100 MB available hard disk space 

Recommended Specifications 

1 GHz or faster processor (32-bit (x86) or 64-bit (x64)) 

512 MB RAM (XP), 1 gigabyte (GB) RAM (Win 7/8/10/11) 

XP Professional SP3 or Windows 7/8 operating system 

128 MB video adapter memory, 1024 x 768 resolution 

200 MB available hard disk space 

File Permissions 

Each instance of PedCath must have read/write access to the Local Program Folder (see 
Appendix A). Each instance must also have read/write permissions to the Data Folder 
and, if you have a Direct Data Import Utility, to the Import Folder. This means that each 
PedCath user must have read/write permission to all these folders on each computer on 
which he/she uses PedCath. 
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Registry Permissions 

Each instance of PedCath must also have read/write permission to the following 
Windows registry keys: 

• HKEY_CURRENT_USER\Software\PedCath 

• HKEY_LOCAL_MACHINE\Software\PedCath 

 

Network Requirements: 

PedCath requires 130Mb of data when first installed. Subsequent cath reports require relatively 
little hard disk space. Each completed cath report typically adds 250K to 500K. If you are 
assigning disk space to the PedCath data folder, 1 gigabyte (1GB) is generally sufficient for 5-10 
years of data for most centers. 

A Windows share folder is recommended to host the database files (Windows XP, 7/8/10/11 or 
Windows Server 2003 and above) 

Network Architecture and Hospital Integration 
The basic PedCath setup consists of the PedCath application set up on one or more workstations (or 
VMs) that connect to the database files in a share folder. With the basic setup, users would type in the 
patient and case measurements and would be able to print a report or save it to a PDF file. Those could 
be manually scanned or imported into the hospital record. 

PedCath also supports additional integration options to reduce data entry and to automate sending out 
the report data. PedCath supports importing data from all the major hemodynamic system vendors to 
bring in patient demographics, case measurements (pressures, saturations, radiation, blood gases), staff, 
and other procedure information and resources. The hemodynamic systems will export a file at the end 
of the case to the PedCath file share (Data_In/ sub folder by default), and the PedCath user will open the 
Import module and choose the patient they’d like to import. Please see the PedCath Imports white 
paper for more information. 

PedCath can also automate sending the report to the EMR or CVIS systems with the optional HL7 / XML 
/ FTP components.  

PedCath does not have ADT or Orders interfaces but will rather pick up the demographic information 
from the hemodynamic system file (and update the data on subsequent imports). If an order number is 
included in the hemodynamics file, PedCath can import it and pass it along to the exports. Please refer 
to the PedCath Exports and PedCath Epic white papers for more information.  

https://www.pedcath.com/pdfs/PedCathExports.pdf 

https://www.pedcath.com/pdfs/PedCathEPIC.pdf 
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Basic Setup Network Diagram 
 

 

User Workflow 
1) The PedCath user creates new patient and cath report records manually. 
2) All hemodynamic measurements (pressures, saturations, blood gases, radiation, height, weight, 

etc.) are entered manually.  
3) The rest of the report components are added (heart diagram, diagnoses, comments, …).  
4) Once completed the report can be printed or saved to a PDF file at any time. Optionally the 

report can be signed/locked by the attending physician to prevent further editing which can also 
serve as a trigger to export the report as a PDF file to a file share for long term storage. 
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Full Integration Network Diagram (PedCath with Hemodynamics monitoring 
system and EMR integration)  
 

 

 

 

 

 

 

 

 

 

 
 
Note that PedCath looks in the Data_In\ sub directory for the hemodynamics files by default and writes 
export files to the export\ sub directory by default. Both of those can be changed to different directories 
if desired. PedCath users would need read/write access to both locations. 
 
The EMR integration will likely be more complex based on your implementation. Typically, the PedCath 
outbound HL7 file will be picked up by an interface server and sent to a document management system 
that will send a reference link to your EMR. 
 
User Workflow 

1) The case is performed and closed on the hemodynamic monitoring system, and the case data 
files are sent to the PedCath import directory. 

2) The PedCath user opens the Direct Data Import Utility module in PedCath, locates the case, 
reviews the data/chooses the best measurements, and imports the data into the PedCath 
database. 

3) The PedCath user completes the report (adds a heart diagram, diagnoses, comments,…). Once 
completed the attending physician signs/locks the case and the report is sent to the hospital or 
cardiovascular medical record. 

Alternately it is possible to create the patient and cath report records manually before running the 
hemodynamics import, to work on parts of the cath report (such as the diagram) before the procedure. 

If the report is rejected by the EMR: 

- Within 24 hours the attending physician should unlock the report in PedCath, fix errors, and lock 
the cath back, which will resubmit the file with a final status. Scientific Software can adjust the 
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System / Medical Record 
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Workstation 
with PedCath 
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grace period time frame for you if you’d like a longer period available to fix issues after a failed 
submission. If you are using the HL7 acknowledgement processing feature, then the user will be 
notified that the report was rejected and the report will be automatically unlocked. 

To make corrections after the final report was accepted: 

- The attending physician would choose the Create Update Report command, make any necessary 
changes and lock back the cath report. The report files will be resubmitted with a corrected 
status and the original data will be retained in PedCath. 

 

Managing User Accounts 
Local user accounts and auto-logins through active directory are supported (see the AD white paper). 

https://www.pedcath.com/pdfs/PedCath_Active_Directory.pdf 

PedCath ships with a default admin account (u: SSS p: PedCath8!). The default password should be 
changed if this account is to be used for administrative purposes, or else the account should be disabled 
if you’re not planning on using it. 

Users should not share a common username. This is against HIPAA regulations and can cause other 
issues as well. 

You can manage user accounts by going to Tools > Options from the main menu and clicking the 
Personnel link.  

PedCath supports four permission levels:  No-Access, View-Only, Full Edit, and Administrator. See 
Appendix B for more information on the permission levels. 

Any personnel that would either need access to the system or who should be listed on the cath report 
would need a personnel record. There is an option to allow full-edit users to add No-Access personnel. 
This can be more convenient for attending physicians to add new referring physicians to the report.  

PedCath requires complex passwords of at least 8 characters by default. Additional password constraints 
can be set here as well. There is an Auto-logoff function that can be set on the Misc panel that will boot 
off users after a period of inactivity. 

Configuration Changes  
Calculation constants, institutional heart sites, import/export options,... would all need to be set by an 
administrator.   

Most options can be set from Tools > Options > Administrator tab. 

It’s recommended to review the settings with your attending physicians and set the options as desired. 
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If your institution would like consistent report setup options, you can configure those globally. Go to the 
Edit Cath screen for any cath report, set up the report components and options as desired and click Save 
Settings and choose to save the settings for all users.  

Backups and Restorations 
All files in the file share should be backed up regularly. A file copy of the share files to another location is 
all that’s needed for the backup. It’s recommended to perform the backup when all users are out of the 
system. When a backup is done it’s recommended to at least backup all database files (those can be 
found in the root of the data folder with the following extensions: [*.dbf, *.nsx, *.smt, *.lfn].  The sub 
folders contain cath resources such as images and documents. Those can grow large so a differential 
backup of the sub folders can be performed if it is preferred over a full backup due to space concerns. 

If you need to restore any individual database files, it’s necessary to restore all files that make up the 
particular table at the same time. The files will have the same file name except for the extension. For 
example, files cathdb.dbf, cathdb.nsx, and cathdb.smt make up the cath table. 

 

Upgrades 
Scientific Software typically releases 2-4 revision updates for PedCath a year, and larger updates every 
couple of years. The revision history is listed online so your institution can better determine which 
upgrades you’d like to apply.  

The current and earlier version installers may be downloaded online here: 

https://www.pedcath.com/?id=updown-pc8 

You will need to know your 4-digit PedCath serial number, which can be found on the Help>About 
screen. An up-to-date license is also required to install the latest updates. 

To update you will simply run the installer on each workstation. It will automatically uninstall an earlier 
version if it is present. Administrator rights to the local workstation is needed to run the installer due to 
several ActiveX dependencies. 

If there is a database update needed, then a database upgrade wizard will run when you start PedCath. 
You will need an administrative login to PedCath to run it. The update web page specifies which versions 
contain database updates. All users would need to be out of the system when that is run. You can see 
who’s logged in and boot off users in the Administrative Console. 

When there is a database update, PedCath will back up files that will be changed before updating them. 
However, it’s recommended to make a full database backup prior to upgrades with database updates 
for an easier restoration if needed (especially when you are upgrading through multiple revisions). 

If you are upgrading through a large number of revisions, you will only need to install the version you 
are upgrading to, and it will apply all DB updates necessary. It’s not necessary to install intermediate 
versions in multiple steps. 
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If it's not known what workstations PedCath is installed on, you can use the View Hosts Listing function 
in the Administrative Console on the View Login Information tab. This will list the host names (with 
computer usernames) for workstations that have ever logged into PedCath (since the login table was last 
cleared).  

If some workstations are not available for upgrade during the downtime period, they will be locked out 
of PedCath until they are upgraded. The user will be given a message saying a later version is installed at 
your institution and an upgrade is required. 

 

Running Database Maintenance 
It's recommended to run maintenance quarterly or when there are database issues. 

Maintenance will run integrity checks, reindex the tables, remove deleted records, and clean up old 
import files. All users would need to be out of the system when this is run. It is possible to start 
maintenance from the command line so it can be scheduled with the Windows task scheduler. 

Maintenance can be run from the Administrative Console program. A reminder can be set up there as 
well. 

More information about database maintenance and other maintenance functions can be found in the 
user’s manual: 

https://www.pedcath.com/pdfs/UsingPC8.pdf 

 

Updating Annual License / Adding Licensed Features 
When your annual license is extended Scientific Software will send you an updated license file 
(pedcath.lic).  

To install the license use one of these two methods: 

For version 8.6.2 or above: 

 From the main menu choose: Help > About 
 Click the Install License button and browse to the file location.  

 
For any version: 

 Copy the license file into the root of the data folder to update it. The license should be reflected 
the next time you open PedCath (the license expiration date is shown on the Help > About 
screen). 

If any licensed features are purchased a new license file will be sent and should be installed in the same 
way. Additional supporting files may be included as well depending on the feature.  
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Managing the IMPACT Registry 
Adding the IMPACT Registry module requires that you are running PedCath 8.4.3 or later. The module 
will be available automatically when applied to your license – no other installation is needed. 
 
There are several configuration options to consider when you first start out using the registry. See the 
IMPACT User’s guide Administration section for more information: 
https://www.pedcath.com/pdfs/IMPACT_Users_Guide.pdf 
 
It’s recommended for users to start IMPACT collection at the beginning of a quarter. 

The IMPACT Registry allows users to submit study data in a quarterly submission file. PedCath does not 
directly submit the file data but will generate a zipped and encrypted submission file that your IMPACT 
clinician will upload to the NCDR’s website. The submission may include PHI, but patient identifiers are 
stripped out by default. There is also an option to remove the SSN field if you do not want that collected. 
 
After the initial configuration, the only ongoing maintenance required is to periodically update the 
device and closure methods. This can be done by clicking a Web Update button in the IMPACT 
administrative options. This can also be handled by your IMPACT clinician if they are given 
administrative privileges. 
 

Getting Support 

Contact Scientific Software for: 
 PedCath-IMPACT module usage questions. 
 Any errors when using the PedCath-IMPACT module. 
 Assistance creating the submission file.  

434-293-7661 
support@pedcath.com 

Contact NCDR for: 
 Assistance uploading the submission file to the NCDR website. 
 General Registry questions 
 Questions about data fields, missing devices, reports... 

800-257-4737 
ncdr@acc.org 

 
 
 
 
 
 



12 

 

IT Tasks - How To Guide 
 

How to log off users 

PedCath requires that all users are out of the system for certain tasks such as running database 
maintenance, when troubleshooting issues, upgrades and migrations. 

If you are not able to reach all users or if it’s not feasible to contact everyone currently in the 
system to request them to shut down PedCath (or kill the process/restart their workstation if it didn’t 
shut down properly), you can boot them off in the administrative console.  

To boot a user open the admin console and click the View Login Information tab. Highlight a 
user that’s logged in and click Boot User. The user will be given a notification to save any work and shut 
down (PedCath will automatically shut down the workstation after a couple of minutes regardless). You 
should see the status changed to shutdown notify and then shutdown acknowledged. If any records are 
stuck in the shutdown notify state for more than 10 minutes, you can remove the record by clicking 
remove record (the machine may have not shutdown properly). It is important to not to click remove 
record sooner or else the workstations will leave PedCath open and stay connected to the database. 
Please note that users that are open to the login prompt will be listed as Connected/Not Logged in. 
PedCath does have the database open at that stage so those machines would need to be shut down to 
run maintenance tools. 

Once all users are out of the system, attempting to start database maintenance will let you 
know if all tables can be opened exclusively (if not you’ll get an error).  

 

Check to see if the files in use outside of PedCath: 

Sometimes even if all users appear to be out of the system, it’s possible that the files may be left 
open somewhere (By PedCath not being shut down properly or by another process). If this is the case 
either check with users that may be in the system and have them shut down or look at the open files 
table for the network share.   

- On the machine where the database files reside (Only if you have a Windows File Share): 

o Start > Windows Administrative Tools 

o Open Computer Management 

o Click Shared Folders > Open Files under System tools 

o If any files are open you can determine who has them open and request that they 
shut down PedCath or restart their workstation. If that’s not feasible then you can 
remove the open files within that tool. 
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Merging patients 

If there are duplicate patient records, PedCath includes a function to merge them into one record, that 
will combine cath reports into the one patient record. 

- On the patient browse screen highlight one of the patients 

- Click Edit > Merge Patient from the menu 

- Highlight the matching patient 

- Choose the demographics to use as the combined record. 

 

The last name and birth date will need to match on the two records in order for matches to show up.  

There is an option to strip leading 0s from the imported MRNs in the administrative Import options, to 
make this issue less likely to happen. 

Merging patient records doesn’t require administrative access. 

 

Moving cath records 

If a cath record was inadvertently added to the wrong patient you can move it to the correct one with 
the Move Cath Report function. 

- On the patient browse screen highlight the cath report you’d like to move 

- Click Edit > Move Cath Report from the main menu 

- Choose the patient record to where the report should be moved. 

 

Updating Diagnostic or Billing Code sets 

The diagnostic codes (diagnoses and procedures that appear on the cath report) and billing codes (ICD-
10/11, CPT codes for billing purposes), are occasionally updated and would need to be updated in 
PedCath. 

Typically, the newest code sets are packaged with the installer so if you are up to date with the latest 
PedCath version you will have the latest code sets installed automatically. Although Scientific Software 
may also send out a mass mailing email with the codes by themselves.   

If you place the code set files into the network folder then each PedCath user will be prompted to 
overwrite the local codes with the network codes if they are different version at startup. (The 
recommended choice to users is to use whichever set is newer). 
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If you plan to keep the latest code sets up-to-date on the network then it’s recommended to copy the 
files from the local data folder (C:\Program Files (x86)\Scientific Software\PedCath\Data) to the network 
following an upgrade.  

Dx Code Files: 

- Files that start with “DIAG_”  

Billing Code Files: 

- Billcode.dbf 

- Billcode.nsx 

 

Recovering lost documents 

 Browse to the PedCath network folder using Windows Explorer/My Computer.  \ 
 Open the folder called "document", and within that open the folder named "report". The path 

should look something like .../PC7_NET/document/report/  
 The filenames are numbered sequentially so if your document was saved recently, it will be one 

of the later files. You may want sort by the modified date to look at files during the time frame 
when your file was saved.  

 When you've found the document you're looking for, copy it to another folder such as the 
desktop.  

 Import the file into PedCath: 
Go to the "Edit Cath Report" screen for the patient where the document was lost. Open the 
Document Manager ("Report Components" > "Document Manager") and click the "Import 
Document" button. Locate your document to open it. The document will need to be saved and 
given a title. 

 

Recovering cached diagrams 

https://www.pedcath.com/pdfs/PedCath_Diagram_Recovery_and_Loss_Prevention.pdf 

 

How to determine configuration paths 

To determine where your data folder, import and export paths are: 

- Data Folder path (set per workstation) 

o From the main screen choose File > Show Data Folder Path 

o Alternately you can if you don’t have access to PedCath you can find the path by 
opening the PedCath Registry Tool program. 
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- Direct Data Import Utility path (where files from your hemodynamics system are sent) (set 
per workstation) 

o From the main menu choose Tools > Import Cath Data 

o The path is shown at the top of the form.  

o The default location is <data folder>\Data_In\ 

- Export path(s) (where cath report files configured in your export settings are sent) 

o The default location is <data folder>\export\ 

o From the main menu choose Tools > Options 

o The export path is shown at the top of the General tab. If “All Copies of PedCath use 
this path” is checked then this path is used for all users. If not then it’s set per 
workstation.  

o Click the Administrator tab and Export link. The file types checked off in the Auto 
column will be automatically sent out based on the trigger (such as when a cath 
report is signed). 

o If HL7 is checked off, click the HL7 button under Advanced Export Options. In the 
Export Location box If a path is configured under “Export to” then HL7 files are sent 
here rather than the general export path.  

o If FTP is checked off, then one or more profiles may be configured to automatically 
send the report files to FTP servers. Click the FTP button under Advanced Export 
Options. Any profiles that show “(Auto Export)” are used when the exports are 
triggered. 

 

How to migrate the database to another location 

See the white paper here: 

https://www.pedcath.com/pdfs/PedCath_Server_Migration.pdf 
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Performance Considerations 
If PedCath is taking a long time to load or to handle operations, there are several things to consider to 
improve performance.  

 

 Consider running PedCath over Citrix/virtualization software for any remote users, rather than 
having a VPN connection to the file share.  PedCath uses a file-share database and can 
dramatically slow down access (for all users) when some users are accessing it directly over a 
VPN.  Using a remote desktop connection to an on-site workstation with PedCath would see 
better performance as well.  

 Have all users log off and run the database maintenance. Turning on the remove deleted 
records option during maintenance will shrink the database which should help speed up loading 
times. 

 Turn on the auto-logoff feature in the Admin Misc settings. Temporary slowness issues can 
occur when PedCath is left open for extended periods of time.  

 Consider moving the PedCath file share to a different server. Some NAS drives have issues with 
multi-user access. On-site Windows server shares are preferred. 

 The audit log can grow quite large so it’s recommended to backup or purge old HIPPA (Audit) log 
entries. There is a function on the HIPAA tab in the administrative console that will move old 
records to backup tables. Those can still be accessible when viewing the logs. There are also 
functions in DB maintenance to backup old records, or purge them. 

 Consider archiving patients to reduce the size of the database (archived patients can be restored 
at any time). Patients can be flagged for archival either manually or through batch operations. 
Batch operations include flagging patients who have not had a case in a specified number of 
years or those included in an MRN list. 

 Clean out old files in your import folder. If you are importing data from your hemodynamics 
system into PedCath, the number of files in the import folder can grow quite large. PedCath 
doesn’t need the files in this folder after they’ve been imported. Old files can be manually 
moved or deleted. There are options in the database maintenance to clean up those files. It’s 
also recommended to have DB maintenance clean out the import index file. 

 Set the default view mode on the browse screen to patient filter search. This will speed up the 
initial load and patient navigation by not loading the patient grid, but allowing you to search for 
patients based on the name or MRN.  

o This is a per-user setting: Tools > Options > User tab > More button > Set Default View 
to Patient Search. 

 If you are connecting to the database server using a DFS path, consider using a UNC or mapped 
drive directly to the server instead. 
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Technical/Security FAQ 
What kind of database does PedCath use? 

PedCath uses the Apollo OLEDB engine that is built into the client software. There is no service needed 
to run on the server. The data table files (.dbf) are dBase III+ format and the compound indexes (.NSX) 
and memo files (.SMT) are a proprietary format of Apollo.  

 

Do I need to open any ports in the firewall for PedCath to work? 

PedCath requires that Windows Printer and File Sharing is enabled, and that read and write access is 
given for users to the share directory. It’s generally not necessary to have to manually open the ports in 
the firewall. Windows file sharing uses TCP ports 139 and 445. 

 

Can I connect to the database directly to do data analysis? 

First be aware that PedCath has a built-in data reports module (Tools > Data Reports) that will allow you 
to query on any of the data elements. 

PedCath uses a dBase file share for the database. The tables with memo fields use a proprietary format 
of the Apollo OLEDB data engine, but there is a function in the Administrative Console that will export a 
snapshot of the database in standard dBase (III+) format.  You would be able to connect to the snapshot 
with Access or using a dBase ODBC connection.  We do not recommend connecting to the production 
database directly. 

Another possibility to get access to the data is to use the batch export feature. PedCath allows you to 
export case data over a date range in multiple available formats (HL7, XML, TXT, PDF), one case per file. 
Scientific Software would need to assist with running the batch export. PedCath can also export the files 
on an ongoing basis whenever the data is either saved or case is locked (however the trigger is set up). 

 

Is PedCath HIPAA compliant? 

Yes, PedCath supports per-user logins and contains an audit log available to administrators. For 
additional information about our annual HIPAA/HITECH risk assessments and security policies, please 
contact Scientific Software. 

 

Does PedCath contain any PII or PHI? 

Yes, the following PHI identifiers are stored in PedCath. 

 Name 

 Birth Date 
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 MRN 

 Cath Procedure Date 

The following fields are also included if you are using the IMPACT Registry module: 

 Zip Code 

 Admission Date and Discharge Date 

 HIC - Health Insurance Claim (HIC) number is the unique identifier issued to all Medicare eligible 
beneficiaries. 

 Research Study’s Patient Identifiers 

 Social Security Number (optional - can be hidden) 

 Date of Death 

 

The medical information in the PedCath report includes measurements related to the cath procedure 
(pressures, saturations, blood gases, radiation), diagnoses and procedure codes, a patient-specific heart 
diagram and medical images, and case staff.  

 

Does Scientific Software manage the database? 

No, the database is managed by your institution and is not accessible to Scientific Software staff.  

 

What do the audit logs track? 

The audit logs track logins/logoffs, cath report views and edits, staff modifications, exports, and errors. 
Please see Appendix C for a full list. 

 

Is the PedCath data encrypted? 

PedCath data is encrypted over the wire (The level of which depends on your Windows file sharing 
settings).  

Most of the data is not encrypted at rest except for authentication settings. Disk-based encryption 
methods such as BitLocker are supported to encrypt all the data at rest. 

 

What kinds of authentication methods does PedCath support? 

Local accounts and LDAP auto-login 
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What login/password constraints and features are available? 

 Complex passwords are required of at least 8 characters (1 upper, 1 lower, 1 number, 1 symbol). 

 Ability to change the minimum password length (between 8 and 15). 

 Ability to force password resets after a specified number of days. 

 Ability to prevent password reuse. The number of previous passwords compared is configurable 
(up to 9). 

 Ability to disable an account after a specified number of invalid login attempts (up to 9). 

 Ability to automatically log off users after a configurable period of inactivity. 

 

Does PedCath support ADT? 

No, this is not supported. The demographic information is typically imported from the hemodynamics 
system. 

 

Does PedCath support an orders interface?  

No, this is not supported. The order number is typically imported from the hemodynamics system if it’s 
needed for filing the report in the EMR. 

 

Is PedCath a high-availability application and what are the downtime requirements/procedures for 
maintenance?  

The PedCath report is generally worked on after the procedure, and the volume of cases is generally 
relatively low so PedCath is not considered a high-availability application. There is a small amount of 
downtime needed for some maintenance functions. 

It’s recommended to run DB maintenance quarterly or when you are experiencing database issues. 
Downtime is also needed for upgrades where there is a database update, and when migrating the 
database to another location.  Troubleshooting issues and other data functions may also require some 
downtime. When working with Scientific Software on DB work or issues they will attempt to make the 
amount of downtime required as little as possible. 

Downtime time estimates: 

 DB Maintenance (15 min) 

 Upgrades (15 min DB update, 5 min per workstation for the client install) 

 DB Migration (1-2 hrs, but depends on the size of your database.) 
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It is recommended to schedule any downtime during off-peak hours so that it doesn’t affect patient 
care. It's recommended to discuss a plan with your care providers.  

Downtime procedures: 

 Notify users in advance to log out of the system ahead of the expected maintenance period.  

 Users still in the system can be booted out with the administrative console tools. (See pg 12) 

 Once the DB maintenance or upgrade is started, all users will be automatically locked out until it 
is completed.  

 When working on issues or longer database work that requires downtime, a DB lock can be 
placed on the database that will prevent users from logging in.  

o In the administrative console > Click the Maintenance tab > Click Set DB Lock 

 After the downtime if a lock was set you can remove it by logging into the Administrative 
Console and clicking “Unlock Database” when prompted. 

 

Can PedCath run on an Apple Mac or Linux machine?  

PedCath is Windows desktop software and will not run natively on a Mac or Linux box. However, you 
can run it using virtualization software such as Parallels (Mac), Wine (Linux), VM Ware (Mac or Linux) or 
VirtualBox (Max or Linux). It can also be run as a thin client (such as through the Citrix web portal).  

 

Does PedCath support a DFS path for the database connection?  

Connecting using a distributed file system (DFS) path does work, however users have reported reduced 
performance when connecting this way. It’s recommended to use a UNC path or mapped drive to the 
server where the PedCath database files resides.  
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Troubleshooting 
Here is a list of common issues and their solutions. 

If additional assistance is needed, please contact Scientific Software.  

support@pedcath.com 

434.293.7661 (8am-8pm EST)  

Scientific Software can provide remote support through WebEx desktop sharing sessions (or can join a 
session provided by your hospital through another vendor (Zoom, Teams,…)).  

Scientific Software will attempt to test and make any necessary changes through the remote session. In 
some circumstances Scientific Software may need some files sent to them to further troubleshoot or to 
make fixes. Be aware that files may include PHI and should be sent securely rather than over email. If 
your institution uses secure email that can be used. Files may also be sent over the sharing session (e.g. 
WebEx, Zoom, Teams), or through a HIPAA compliant dropbox (e.g. OneDrive, Box, DropBox). Scientific 
Software will use your preferred method. 

Installation 
Problem:  During the installation you receive error 1904 Module C:\Windows\SysWow64\tx4ole31.ocx 
failed to register. 

Solution:  
Redownload the installer from the web site to ensure it is the latest package and try again.  

Installing Visual C++ Runtime 2013 (x86) runtime prior to installing PedCath should fix the issue as well: 

https://www.microsoft.com/en-us/download/details.aspx?id=40784 

 

Startup 
Problem:  PedCath is slow to open 

Solution:  
See the section on Performance Considerations. 

Shutting down all users and running database maintenance can fix performance issues as well.  

 

Problem: PedCath cannot locate the data files 

Solution: 
On a newly setup workstation this is normal as the database path hasn't been set yet. The next step will 
prompt you to browse to the data path. If this machine has already been configured for PedCath you'd 
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need to verify that you have read/write permissions to the database folder.  You can check to see how 
the current path is configured by opening the PedCath Registry Tool program. Try to open the path in 
Windows Explorer to verify you can see it. 

 

Problem: PedCath prompts for the network path each time it starts up.  
 
Solution:  
PedCath is not able to save to the registry. The path may be set by having an Administrator log on to the 
computer and set the network path for PedCath, or by granting access by setting the Read/Write access 
to the PedCath HKLM registry key.  

 

Problem: You receive one of these errors at startup: 

 File open error 1800 file access error cannot open globalop.dbf (also useranat.dbf or patdb.dbf). 

 Error A2-600: Cannot open database file: 'patdb.dbf'  (The following error occurred while 
attempting to open the database files: Error A2-600) 

Solution: 
Check that the currently logged in user has read-write permissions to the data folder. 

If they do, try shutting down all users and running database maintenance. 

If that doesn’t fix the issue and database maintenance indicates there’s an issue with some tables (or 
crashes) you may need to restore particular database files from the backup or perform a full backup. It’s 
recommended to contact Scientific Software for assistance. 

 

Problem: Error x-339: Component '<name of control>' or one of its dependencies not correctly 
registered: a file is missing or invalid. (example controls:  vsFlex8n.ocx , Vsflex7L.ocx,  XceedZip.dll, 
RICHTX32.OCX) 

This also applies to: 

 Error 1011-372 Failed to load control 'VSFlexGrid' from vsFlex8n.ocx 

 Error 1011-339: Component 'RICHTX32.OCX’ 

Solution:  
Go to the Windows Start Menu and Select “Run…”  
Type: "regsvr32 <name of control>" (without quotes)  
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Click OK.  
You should see a message that says, "DllRegisterServer in <name of control> succeeded."  
 
If this doesn't help or if this error started happening after an upgrade, it's recommended to install the 
full Windows installer from our update page, which will ensure that all third-party controls are installed 
properly. This error can sometimes be the result of using the legacy update file (.p7u) where the user 
doesn’t have permissions to update the dependencies or if another program installed a different version 
of a dependency PedCath is using.  

 

 

Problem: You receive a message that your diagnostic code or billing codes are out of sync with the 
network.  
 
Solution:  
This is not an error but can indicate that your local lookup table (what PedCath actually uses) is different 
from what is on the network (the "master copy"). Choosing the recommended choice will make sure 
that you are running the later version.  
 

Login 
Problem: PedCath cannot find your username. 

Solution: 
Make sure you are using your PedCath username (it’s not necessarily the same as your Hospital AD 
login). If PedCath still cannot recognize your initials, ask an Administrator to determine your log on from 
the PedCath Personnel list. 

 

Problem: I forgot my password. 
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Solution:  
Have an administrator log in and reset your password:  

 From the PedCath main screen (Tools >> Options) 

 Click the Administrator Tab, click the Personnel button and click Password Reset. 

 The user can log back on with the initial password Taussig1! (or Taussig for versions prior to 
8.5). 

Note:  

 If you do not have a PedCath administrator (or they don’t know their login information), contact 
Scientific Software. 

 If you are logging on to PedCath with a shared computer, check the login initials to make sure 
they are your own. 

 

 

Problem: You receive the following message after logging in:  
“The last time you logged onto PedCath you were not properly logged out. This could be because 
PedCath terminated abnormally …”  
 
Solution:  
If you receive this message first make sure that you are not logged into PedCath from another 
computer. If you are editing a cath on another computer and choose to log in, you will lock yourself out 
of the cath report on the other computer, possibly losing changes you’ve made if you haven’t saved your 
work.  
 
You will also receive this error after a program crash or other abnormal termination. In the case of an 
abnormal shutdown, your patient lock will still be registered with the PedCath databases (which is what 
will trigger this message), and logging back in will clear the lock.  
 

Problem: You receive the message: "This version of PedCath is licensed for a maximum of one user at a 
time."  
 
Solution:  
This means your institution has a single-user license and another user is currently logged in to the 
system. They would need to log out for you to be able to log in. If the other user’s PedCath did not shut 
down properly it’s possible their login record is stuck in the system. If this is the case if that staff 
member logs in and back out it will clear out the lock.  

An administrator can also boot off the user or clear the record in the administrative console. See the 
how-to section on booting off users. Contact Scientific Software if you are running version PedCath 7.4 
or below. 

Scientific Software can assist upgrading your license to support multiple concurrent logins if desired.  
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Editing a Cath Report 
Problem: You receive a message saying that a patient is locked by another user.  
 
Solution:  
Verify that the staff member is not actually logged onto the system. If they are not in the system, they 
may have terminated PedCath abnormally. If this is the case, the person who has the patient locked 
should log back into PedCath, which will clear the lock. An administrator may also remove the lock in the 
Administrative Console. 

 

Problem: When loading a cath report PedCath hangs and gives you Error 6420 waiting for lock.  

Solution: 
If no one is currently editing the case you can fix this issue by running maintenance with the “Remove All 
Record Locks” option turned on. 

 

 

Problem: When loading or saving a cath report you get error LDB-13 or WDB-13 Type mismatch. 

Also applies to Error 106-13: Type mismatch. 

Solution:  
This error generally occurs if a value out of range is brought over during an import. This may possibly 
indicate an invalid mapping. If you see that you are missing data on the Edit screen, do not save the 
report as you may overwrite some valid data with blank data.  

If this is a recently imported file without any additional work done you could verify that all data is 
present in your hemodynamics system, reexport it, and import it again into PedCath. On the import 
review screen you could also choose to not import any invalid values (values that are negative or large 
numbers) by clicking the dropdown in the PedCath column and choosing “don’t import” next to any 
fields with bad data.  You may be able to fix the error with existing cases by running database 
maintenance with the option to Fix Field Errors turned on. Contact Scientific Software if the error 
persists. 

 

Problem: LDB-7100: Invalid Hemoset Index 

Solution: 
It’s recommended to reimport the case from the hemodynamics system. If work has already been done 
on the cath report you could alternatively delete the hemodynamic sets, and run the import into 
existing cath command (on the Edit Screen File menu) and only import the hemodynamics data.  

Scientific Software can also help fix your table data manually over a remote session to correct the invalid 
set numbering. 



26 

 

Upgrading to version 8.4.4 or later will automatically fix those errors when you load the case. 

 

Problem: Error Message: The following error occurred while attempting to load the cath from the 
database: Error LDB-514: Error in cath table (2).  

Solution: 
Two or more cath records were assigned the same internal cath ID.  

It’s recommended to run the database maintenance with the “Check Duplicate Ids”/”Fix Errors” options 
turned on. This will fix any duplicate Ids for patient records or cath reports. 

The administrative console will list the cath numbers for the reports that had duplicate Ids that were 
fixed. It’s recommended for a physician to thoroughly inspect all cath records whose ids were fixed.  The 
child records of the cath record (hemosets, diagnoses, diagrams, documents, images) may be 
mismatched and would need to be fixed manually (you could also run the “Import Into Existing Cath” 
command from the edit screen File menu to reimport the hemodynamics from the hemodynamics 
system).  

 

Problem: Error Message: The following error occurred while attempting to load the cath from the 
database: Error LDB-514: Patient not found. 

Solution: 
It’s recommended to run the database maintenance with the “Orphan Finder”/”Fix Errors” options 
turned on.  

 

Problem: You get a Windows Delayed Write Failed message possibly followed by a Data Driver Error 
9000 or 2100.  
 
Solution:  
This can usually happen due to a temporary loss of your network connection or other network issues. If 
you are working on a cath report you will likely lose any unsaved data. Close PedCath and browse to the 
network location with Windows Explorer or My Computer to see if it is available and if not check with 
your network administrator to see if there have been any network issues or configuration changes. Fast 
access to the network share over a wired connection is recommended for PedCath. 

It's also recommended that database maintenance is run. 

 

Problem: Some of the cath report data is missing on all cases.  
 
Solution:  
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It’s recommended to run database maintenance to reindex the tables. If the problem persists contact 
Scientific Software to help inspect for corruption. 

 

Problem: When attempting to open the Edit Cath screen you receive error 136-603: Multiple login 
records found.  
 
Solution:  
Your user record is in the database multiple times. PedCath may have not closed down properly on a 
prior workstation you were working on. A PedCath administrator should remove the prior record in the 
Administrative Console. If a duplicate record isn’t shown or if removing it doesn’t help it’s recommended 
to run the Clear Login Table command when all users are out of the system. 

Diagram Editor 

Problem: PedCath crashed while editing a diagram. Is it recoverable? 

Solution: 
The cached version of the last time you saved may be recoverable. See the white paper here for 
recovery instructions and tips to prevent crashes: 

https://www.pedcath.com/pdfs/PedCath_Diagram_Recovery_and_Loss_Prevention.pdf 

 

Problem: The Embed button is greyed out so I’m not able to embed measurements.  

Solution: 
If the diagram you are using is not linked to an original diagram from the Mullins and Mayer atlas 
PedCath will not be able to automatically embed numbers on it. To tell if it is linked, the Mullins ID 
should be listed above the embed button with a non-zero number. If the diagram was imported from a 
file or a user diagram where the Mullins Id wasn’t specified, then you won’t be able to automatically 
embed measurements. If the links are missing in any diagrams in the user’s atlas, those can be fixed by 
clicking the “Edit Title / Mullins ID” button and entering the appropriate source Id. 

If you are having issues with diagrams imported from patient templates, then upgrading to version 8.6 
or later may fix the issue. 

Running the patient template fixer program may also help if you’re running version 8.5.9: 

https://www.pedcath.com/dl/PedCath859PatientTemplateFix.exe 

 

Problem: I’m not able to move the measurements or other objects around on the diagram.  

Solution: 
To move measurements and other objects around make sure the arrow tool is selected in the toolbox 
(you can also right-click an object to select it) and then you will be able to click and drag the objects to 
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another location. Once the diagram is saved or if the flush command is used you will no longer be able 
to move them around on the diagram. 

 

Problem: The hemodynamic grids aren’t showing on the diagram editor.  

Solution: 
When new diagrams are added to PedCath they are automatically associated with any existing 
hemodynamic conditions. However, if sets are added after the diagrams they would need to be 
associated to each diagram by highlighting the diagram in the diagram manager and checking off each 
set it should be associated to. All associated sets will then be available in the diagram editor. 

 

Document Manager 
Problem: Error Message: The following error occurred while attempting to import the document: Error 
110-75: File cannot be opened.   

Solution: 
Make sure you are importing the document from a location that PedCath has access to and that it’s not 
currently open in another program. 

Scientific Software can check your document file to see if there are any incompatibility issues. 

A work-around would be to create a new document in PedCath and copy-and-paste the document 
contents from Word into the PedCath document editor. 

 

Problem:  When attempting to add document template to the cath report you receive the following 
error message: The following error occurred while attempting to save the document as other format:  
Error 710-715: File extension not recognized. 

Solution: 
PedCath will not be able to add the file to the cath report if it was imported into the document archive 
in version 8.6.1 or earlier, with a filename greater than 40 characters. Reimporting the document into 
the archive in version 8.6.2 or later, or reimporting it in a prior version will a filename with less than 40 
characters will fix the issue. If you don’t have the source document available, Scientific Software can 
help you recover the document from the PedCath data share. 

Printing Reports 
Problem: Error Message: The following error occurred while attempting to setup the report: Error 504-
599: Argument out of range. 
 
Solution:  
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This error could mean that the page size reported by your default printer is too small for the PedCath 
report. Make sure your default printer in Windows is set to letter size or larger. 

 
Problem: When printing or print previewing a report, most or all of the text is missing.  
 
Solution:  
This is usually a problem that is related to a specific printer setup or printer driver.  
1) Configure the printer to use True-Type fonts. 

 
Open the property pages for your printer:  
 
Start Menu >> Settings >> Control Panel >> Printers  
 
Right click your printer icon and choose properties.  
 
Look through the property pages of the printer for a reference to TrueType fonts and select the 
'Always use TrueType fonts' (some printers have a checkbox to ‘download TrueType fonts as 
bitmaps' or something similar to that). Sometimes this is difficult to find but will usually solve 
the problem.  

2) If the above solution doesn’t work contact your vender to get the latest printer driver. 
 

Problem: My report doesn’t print.  
 
Solution:  
Attempt to print a test page through another application such as Microsoft Word. If this doesn’t work 
then the printer is not configured properly on your computer. Contact your system administrator for 
help setting up the printer. 

If you aren’t able to view the print preview, contact Scientific Software to further troubleshoot. 

 

Problem: Error Message: The following error occurred while attempting to create signed by string: Error 
297-101: Application-defined or object-defined error  
 

Solution:  
Check that your staff record has a Display name set and set it if not. Also try refreshing the patient list on 
the browse screen (F5), and unlocking/relocking the report if that doesn’t help. 

 

Problem: Error Message: The following error occurred while attempting to export the cath report as a 
PDF file: Error 168-641: PDF file not saved, possibly out of disk space.   
 
Solution:  
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This can be caused by a dependency version mismatch and reinstalling PedCath will fix the issue. 

Also check the disk space for the target file location. 

If you aren’t able to view the print preview, contact Scientific Software for further troubleshooting. 

 

Imports 
Problem: A patient isn’t showing up in the import list.   

Solution:  
Once a file has been transferred to the PedCath import directory it should show up immediately in the 
Direct Data Import Utility listing.  

 The import list doesn’t auto-refresh, so try closing and reopening the import module to ensure 
the latest files are loaded. 

 Check your import filter by clicking the “Filter Options” button and make sure the file export 
date would be within the specified range. 

 If your institution has set up a batch process that periodically moves the files from your 
hemodynamics system to the PedCath directory, then it may take some time for it to show up. 

 Verify that the appropriate triggers were performed in your hemodynamics system that are 
required to send out the case data (e.g., specify case complete). 

 If you are using the advanced import filter to filter files based on staff names check to see if the 
file may be getting filtered.  

o Tools > Options > Administrator tab > Import > Import Filters button (if the button is 
greyed out then you are not licensed to use that feature). 

o If “Use Staff Filter” is checked then make sure one or more of the physicians involved in 
the case are included in the list.  If you update the filter list and “Delete Non Matches” is 
already checked you would need to reexport the file from your hemodynamics system. 

 Search for the patient and cath report on the patient browse screen to see if they already exist 
in your PedCath database. If another user imported the study data, the study may no longer 
show in the import list depending on your cleanup options. It’s recommended to refresh the 
patient list (F5) before searching. 

 Verify that the file is in the transfer directory. The directory is shown at the top of the import 
module. Open the directory in Windows Explorer and try to locate it (sorting by the Date 
modified column may be helpful). Most import files can be opened in a text editor such as 
NotePad. Try searching for the patient’s last name, MRN or case identifier within the editor. If 
the file isn’t in the folder, contact your hemodynamics system vendor for assistance. If you find 
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the file with a .bak extension it may have already been imported. If you rename the extension to 
match the other imports it should show up in the import utility list. 

 

Problem: When viewing the import module, one or more files are showing < error opening file > 

Solution:  
Verify that the required demographic fields are included and valid and reexport the file from your 
hemodynamics system if needed.  The required fields are patient name, MRN, birth date, and cath date. 
Also verify that you are importing files from your hemodynamics system and that they are the correct 
type. Scientific Software can help you determine why the files are having issues. 

 

Problem: I’m not able to find a cath report that I thought had been imported. 

Solution:  
If you load the import module, and see the patient listed in red then the cath report exists in the 
PedCath database (the patient may not show at all after the import depending on your cleanup options).  
If the patient shows in grey or yellow then a matching patient wasn’t found. To search for the patient, 
on the browse screen try refreshing the patient grid (F5) to ensure the grid is up to date. Try searching  
for the cath report multiple ways with the find tools (such as by name, MRN, cath number (which 
requires viewing by cath report)). If you use the View > By Cath Report mode you can view all the cath 
reports by date. 

 

Problem: Not all the data is transferring to PedCath during the import. 

Solution:  
The import review screen shows what data is available for import from your hemodynamics system. If 
the hemodynamics grid is empty that could indicate that you could be using a file that was exported 
before hemodynamics were added. The right-hand columns of the grids (with a white background) show 
how the data will flow over into PedCath. If those cells are blank or unchecked then the corresponding 
element will not be imported. You will need to map staff to the PedCath staff record when you’re first 
staring out with the import (by setting the matching staff record and role in the third and forth 
columns). Those staff member mappings will be remembered for future cases.  

If particular heart site measurements are incorrect or missing, or you would like to alter where some 
values are taken from, you can edit those in the mappings. You can modify those by clicking the 
Mapping button on the Direct Data Import Utility. Administrators can edit the mappings (if you don’t see 
the button you can turn it on in the options (Tools > Options > User tab > More button > Check “Show 
import mapping configuration button”).  It’s recommended to work with Scientific software on altering 
the mappings. 

Some values do not transfer over such as O2 Consumption and diagnoses/procedures. 

Please refer to the user guide for more information on using the import utility. 
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Problem: Error Message: The following error occurred while attempting to read the selected file: Error 
99-0 

Solution:  
That error means multiple patient records exist in the database with the same name as the import file. 
Please verify that the demographic information is correct in the PedCath patient records, as well as in 
the import file. If multiple patient records refer to the same patient, then they should be merged. 

 

Problem: There is redundant hemodynamic information on the cath report due to the measurement log 
document. Can it be turned off? 

Solution:  
Depending on what’s included in your procedure notes document generated during the import, the 
hemodynamics may be repeated in the measurement log. If this is the case you can turn off the 
measurements log document in the import options (Tools > Options > Administrator > Import). This will 
not affect the measurement log interface on the edit screen to be able to view the log and drag-and-
drop measurements (F11). You could alternately opt to generate the log and uncheck it as one of the 
documents used in the cath report. 

 

Problem: Error 134-53: File not found  

Solution:  
It’s recommended to wait until the import grid fully loads before attempting to import a file. The filter 
options can be altered to a smaller date range and the import options can be turned on in the 
administrative options to speed up importing.  The error could also mean another user imported and 
deleted the file before you had a chance to. 

 

Problem: Error Message: The following error occurred while attempting to delete the import file: Error 
220-75: Path/File access error 

Solution:  
Make sure you have read/write access to the import directory (shown at the top of the Direct Data 
Import Utility). 

Problem:  Error Message: The following error occurred while attempting to open the file: Error 124-9: 
Subscript out of range  

Solution:  
If you are using Philips Xper, it’s recommended to update to the latest version of PedCath. 

 



33 

 

Problem: Error Message: The following error occurred while attempting to open patient xml file: Error -
901: Can't open the PedCath XML file. 

Solution: 
The menu command File > Import PedCath XML should be used to import XML data previously exported 
from PedCath and not data coming from your hemodynamics system. To import data from your 
hemodynamics system, go to Tools > Import Cath Data from the main menu to load the Direct Data 
Import Utility. 

Exports 
Problem: A report I locked isn’t showing in the EMR. 

Solution:  
Whenever a report is locked PedCath will export the report files based on your auto-export settings. The 
export files should be immediately available in the export folder. It’s possible that it may take some time 
for the files to be picked up if you have a process that picks up the files at scheduled intervals. 

 If you received any error messages when locking the report the files may not have been 
generated. Error messages are logged to the HIPAA log. 

 Try to view the print preview for the report to see if there may be issues generating the report. 

 Determine if the files are in the export folders or FTP sites (to determine the export locations 
see the How to determine configuration paths section). There is also an export log file 
(pc8_export.csv or pc8_export.log) in the main export folder with a list of the exports. If the files 
are in the log but not the export folder they may have already been picked up and deleted from 
that folder.  

 Determine if the case identifiers are correct. On the cath edit screen if you go to View > 
Administrative Fields, you can view the order number, accession number, account number and 
other fields. Those can be manually fixed if incorrect. Scientific Software can help you make the 
order number field editable if desired. If those are incorrect the report may be rejected or filed 
in the wrong location. 

 View logs of your EMR or interface server to see if there’re any errors provided. 

 

PedCath reports are typically small (<1Mb) but on some occasions can grow large if there are many 
snapshot images and some HL7 engines may not be able to handle them. In that case consider either 
manually exporting and importing the PDF or else remove the snapshots and only send the summary 
page and narrative notes if present. 

If you need to resend the report as is, you can run the File>Run Auto Export command. 

If changes need to be made to get the report to file, choose File>Unlock Cath Report, make the 
necessary changes and then Choose File>Lock Cath Report. It’s recommended to have the Attending 
Physician review and lock the report back so that their name will show as the person who signed it.  
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If there is already a final report in the EMR then the File>Create Updated Report command should be 
used (rather than unlocking the report) to make any changes to locked reports so that the report will be 
resent with a corrected flag. 

 

Problem: Error Message: The following error occurred while attempting to export the cath report as a 
HL7 file: Error 170-9: Subscript out of range  
 
Solution: 
if "Use Thermo CO" is checked off on the calculation override section, make sure there is a value set for 
the Thermo CO on the hemodynamics tab. 
 
You may also try temporarily disabling the full text report that’s embedded in the HL7 message in the 
Advanced Export Options > HL7. 
 
If those don’t help, try upgrading to version 8.6.0 or later. 
 

IMPACT Registry 
Problem: When attempting to save an Episode or IMPACT study you get a message “A cath for this 
episode of care has a cath lab arrival date prior to the hospital arrival date.” 

Solution 1:  
Upgrade to version 8.5.8 or later. The cath lab arrival date was used only for IMPACT v1 and was left in 
the validation check in earlier versions. 

Solution 2:  
Scientific Software can help you remove the bad field data through a remote session.  

 

Problem: Some of the data fields are greyed out or not editable in the IMPACT module. How do I edit 
those? 

Solution: 
Some of the data fields are shared with the PedCath report and are not editable from the IMPACT 
module. Those would need to be modified on the cath report. See the “PedCath Cath Report/IMPACT 
Shared Data” section of the IMPACT user’s guide for a list of the fields and how each one is sync’d.  

IMPACT data that is shared with the cath report is also locked down once the cath report is locked. For 
instance if the IMPACT codes are used for the PedCath report, then those would all need to be entered 
before the report is locked. If that isn’t possible, an updated report can be created in order to make 
changes. 
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Problem: You receive a submission error 2099 “Duplicate episodes of care were found based on the 
arrival date information provided.” 

Solution:  
Highlight the patient on the browse screen and choose IMPACT Registry > Patient Episode of Care list. 
See if there are any duplicate episodes with overlapping dates and delete one of them. 
Then click on each cath report on the browse screen for that patient and for any without 
arrival/discharge dates set underneath the grid, click the Set EoC button and choose the correct episode. 
 

Problem: You receive a submission error 2200 “EPAblationOutcome has been reported even though 
EPTargetSub does not require it.” 

Solution:  
The Outcome of Ablation field has a value set when it should be cleared. It’s recommended to change 
the targeted substrate temporally to something else and then click a choice in the Outcome of Ablation 
and then right-click it and choose “Clear Control”. Then change the targeted substrate back to the 
correct value. 
 
 

Misc 

Problem: The following error occurred while attempting to create an email: Error 127-48389 (and run 
time error 32053). 

Solution:  
The Windows MAPI interface doesn’t support launching a 64-bit version of Outlook from a 32-bit 
application (PedCath). If you receive errors when composing emails from PedCath (and are running 
Outlook for your email client), it’s recommended to change the setting to Outlook object model.  The 
setting can be changed by going to Tools > Options and clicking the User tab. 

All reports can also be saved to a file and attached to an email manually if needed.  

 

Updating 
Problem:  Error 1006-5: Invalid procedure call or argument (The following error occurred while 
attempting to load PedCath) 

Solution: 
This indicates the user is running an earlier version of PedCath than other users. Update Wizard requires 
elevated permissions to run. Running PedCath as an administrator or running Update Wizard directly 
should fix the error and apply the update.  An administrator could also run the full installer, or to push it 
out another way such as with packaging software. 
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Another cause to this issue could be the code set sync. Try disabling the code set sync at startup.  

If you’re able to get into PedCath: 

- Tools > Options 

-  Click More on the General tab 

-  Uncheck Sync codes on startup 

If you’re not able to load PedCath you can edit the values directly with the RegEdit program. 

On the Windows Start menu type RegEdit and press Enter. 

Browse to this key: 

HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\PedCath\Main 

- Set SyncCodeSets to False 
- Set ReindexLocal to False 

 
 
Problem:  Error 1564-5: Invalid procedure call or argument (The following error occurred while 
attempting to run institutional-wide upgrade). 

Solution: 
This indicates the user is running an earlier version of PedCath than is set up by the institutional-wide 
upgrade (set up in the Administrative Console). Update Wizard requires elevated permissions to run. 
Having the user run PedCath as an administrator if they are able should allow the update to be applied.  
An administrator could also run the full installer, or to push it out another way such as with packaging 
software. 
 
If the users do not have permissions it's recommended for an administrator to manually run the update 
or full installer, or to push it out another way such as with packaging software. 
 

Administrative Console 

Problem: File open error 1800 when opening DB maintenance. 

Solution: 
This generally means that someone has PedCath open. All users need to be out of PedCath when 
running maintenance.  See the section on how to boot off all users. 

 

Problem: DB maintenance crashes in the middle of it running. 

Solution: 
Database maintenance may crash if there are any corrupt files. If it crashes, restart the administrative 
console. You will be prompted to delete and rebuild the indexes, choose yes and attempt maintenance 
again. If that doesn’t fix the issue contact Scientific Software for assistance.  
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Appendix A: Glossary 
Administrative Console 

A program that allows a PedCath Administrator to perform various administrative tasks 
without having to open PedCath. The Administrative Console is installed with PedCath, in the 
Program Folder and is accessible via the Windows start menu. 

Data Export 
PedCath can export data in a variety of formats, manually and/or automatically. 

Data Folder 
This is the folder that contains all the PedCath database files. It also contains image files, 
document files and various other files that are part of the PedCath data and/or are necessary 
for PedCath to operate properly. The Data Folder can reside anywhere on the network, as long 
as each running instance of PedCath has read/write access to it. 

Data Import 
PedCath has the ability to import data from most major hemodynamic monitoring system in 
use today. Please contact Scientific Software Solutions, Inc. for more information if you do 
not already have Data Import features enabled. 

 Direct Data Import Utility (see Data Import) 

Export Folder 
This is a folder where PedCath will save Patient Reports if the automatic export feature is 
enabled. PedCath will need write permission to this folder. 

Import Folder 
This is the folder where PedCath will expect to find files exported from your cath lab after the 
case. Usually, this is a permanent location on the network, but it can be any physical medium 
used for transporting data if necessary. PedCath must have read access to this folder, and will 
perform best if it also has write access to it. 

Local Program Folder  
This is the folder into which PedCath is installed on a local machine. PedCath needs to read 
and write to this folder during normal operation. 

Program Folder (see Local Program Folder) 

Update Wizard 
An application that users can use to update PedCath to the latest version over the Internet or 
to any version by using a PedCath update file (*.p7u). The Update Wizard is installed with 
PedCath, in the Program Folder and is accessible via the Windows start menu. 
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Appendix B: Permission Levels 
 

Action Admin Full 
(Edit All) 

View Only 

Enter PedCath  X X X 

Add, Edit Patient X X  

Delete Patient X X  

Add, Edit Cath Record X X  

Delete Cath Record X X  

Add Personnel X X  

Edit Personnel Display, Initials X   

Edit Other Personnel Data X X  

Delete Personnel X   

General (Local) Options X X X 

User Options X X X 

Global Options X X  

Administrator Options X   

Add, Edit, Delete Documents X X  

Edit Cath Personnel List X X  

Add, Edit, Delete Hemodynamic Data X X  

Add, Edit, Delete Diagrams X X  

Add, Delete Diagnoses X X  

Add, Edit, Delete Images X X  
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Add, Edit, Delete Comments X X  

Import Cath Data X X  

 

 

Appendix C: PedCath Logging 
PedCath tracks cath views and edits in compliance with the Health Insurance Portability and 
Accountability Act (HIPAA). When a user opens the PedCath Edit screen, PedCath will log information 
about the cath that was viewed, the staff member who viewed it and the date and time (either the local 
or server time can be used based on your settings).  If the staff member edits and saves the cath then 
PedCath will log this as well. 

PedCath also logs anything exported from the system such as when any reports are printed, saved, or 
emailed. This includes the main PedCath report, a report from the data reporting module, the staff 
listing report, or a patient’s billing information.  

Other items logged include logins/logouts, data queries, access configuration changes, and error 
reports. 

The following shows the full list of actions logged.  
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PedCath logging data may be viewed from within the Administrative console on the “View HIPAA” tab. 

PedCath 8.6.3 and above will save the log to a .CSV file, and that file can alternatively be viewed with a 
spreadsheet program by staff who have access. 

Please refer to the HIPAA log configuration white paper for information about configuring the log and 
setting the appropriate permissions. 


